home recent topics recent posts search faq  

Schaudin.com Forum



register | lost password | |
Messages in this topic - RSS

Home » RC-WinTrans Support » Command Line not works on Windows 7

For support issues and specific questions related to RC-WinTrans' use, features and functions.
12.02.2011 21:36:17

Samuel12
Samuel12
Posts: 1
Hello,

the RC-WinTrans command line tool does not work on my Windows 7 (64bit). It was OK on my Windows XP.

I get the following error message when running the "rwtcmd.exe" (with any command):

"Unable to cast COM object of type 'RCWinTrans.ApplicationClass' to interface type
'RCWinTrans.IDualRWTApp'. This operation failed because the QueryInterface cal
l on the COM component for the interface with IID '{B3DB1E36-4E42-4D4C-A738-1DDE
AA83A381}' failed due to the following error: Library not registered. (Exception
from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED))."

I'm using RC-WinTrans 9.1 from January 2011.

Can anybody help ?

Thanks, Samuel
0 permalink
14.02.2011 19:57:43

Support
Support
Administrator
Posts: 216
Hello Samuel,

this is a known problem. During the installation of RC-WinTrans on Windows 7 the RC-WinTrans application object is not successfully added to the Windows 7 registry.

Check the "Known Issues" section here in the forum for a description of the problem and its solution:
http://www.schaudin.com/forum_srv/topic24-windows-7-com-object-and-command-line-failed.aspx

Regards,
Support, Schaudin.com
edited by Support on 15.02.2011
0 permalink
11.05.2011 14:12:30

rboutilier
rboutilier
Posts: 11
From my experience, this issue can be avoided by running the installer "as Administrator" by right-clicking on the installer and selecting "Run as administrator". This should be a fairly easy to fix in the InstallShield project by setting the required execution level of the installer to "Administrator".
0 permalink
25.10.2012 10:37:20

Jan
Jan
Posts: 1
Hello schaudin team,

the suggested solution works on windows 7 32bit but does not work on windows 7 64bit (Tested on serveral machine, has nothing to do with side by side installation rc-wintrans 7) The interesting thing is that the regcheck tool seems to be happy with the installation: Application Object and Type Library are found, at least the way the test tool looks for them.

Trying to create the IDualRWTAppPtr Application Object

[font=Consolas]IDualRWTAppPtr spApplication;
HRESULT
hRef = spApplication.CreateInstance(L"RC-WinTrans.Application");

leads to "Server Execution failed" Error 0x80080005

Neither RC-WinTrans.Application are registered within HKEY_CLASSES_ROOT nor the associated CLSID {06CD89C8-AE90-469D-892E-2F9E41236B7A}
It seems as if the HKEY_CLASSES_ROOT stays absolutly untouched while manually trying to register the com automation stuff as mentioned within http://www.schaudin.com/forum_srv/topic24-windows-7-com-object-and-command-line-failed.aspx

Using current RC-WinTrans 9.2 Global 9.2.0.5 (April 2012)

Help appreciated

Jan[/font]
edited by Jan on 25.10.2012
0 permalink

Home » RC-WinTrans Support » Command Line not works on Windows 7





Powered by AspNetForum 6.9.6.0 © 2006-2010 Jitbit Software